Ruby railsインストール時にエラー「Error installing rails: nokogiri requires Ruby version >= 2.3, < 2.7.dev. The current ruby version is 2.7.0.0.」によって失敗する場合の対処法

Ruby railsインストール時にエラー「Error installing rails: nokogiri requires Ruby version >= 2.3, < 2.7.dev. The current ruby version is 2.7.0.0.」によって失敗する場合の対処法

windows環境でrailsをインストール時に、エラー「Error installing rails: nokogiri requires Ruby version >= 2.3, < 2.7.dev. The current ruby version is 2.7.0.0.」が発生した場合の対応方法です。

環境

  • OS  windows10 pro
  • Ruby 2.7

エラー全文

railsインストール時に発生したエラー全文となります。

対処法

まず下記のコマンドで必要パッケージをインストール。

インストール後に下記のコマンドを実行後に再度、railsをインストールすると解決しました。

再実行

バージョン確認