pecl mcryptインストール時にエラー「pecl/mcrypt requires PHP (version >= 7.2.0, version <= 7.3.0, excluded versions: 7.3.0)」が発生してインストールできない場合の対処法

pecl mcryptインストール時にエラー「pecl/mcrypt requires PHP (version >= 7.2.0, version <= 7.3.0, excluded versions: 7.3.0)」が発生してインストールできない場合の対処法

peclでmcryptインストール時にエラー「pecl/mcrypt requires PHP (version >= 7.2.0, version <= 7.3.0, excluded versions: 7.3.0)」が発生してインストールできない場合の原因と対処法を記述してます。

環境

  • OS ubuntu 20.04.1
  • php 7.3

エラー全文

「sudo pecl install mcrypt-1.0.1」実行時に発生。

原因

phpバージョンとインストールしようとしているmcryptのバージョンが異なるため

対処法

7.3より上のバージョンのphpの場合は「mcrypt-1.0.2」をインストールする