Symfony「composer require server –dev」実行時にエラー「 Could not find package symfony/web-server-bundle in a version matching 5.1.* 」が発生した場合の対処法

Symfony「composer require server –dev」実行時にエラー「 Could not find package symfony/web-server-bundle in a version matching 5.1.* 」が発生した場合の対処法

Symfonyで「composer require server –dev」実行時にエラー「 Could not find package symfony/web-server-bundle in a version matching 5.1.* 」が発生した場合の原因と対処法を記述してます。

環境

  • OS  ubuntu20.04
  • Symfony 5.1.2

エラー全文

「composer require server –dev」実行時に発生

原因

Symfony5系だと「composer require server」は現時点2020年7月時点では利用できない

対処法

phpコマンドを利用する