rails6 pgインストール時にエラー「An error occurred while installing pg (1.2.3)」が発生した場合

rails6 pgインストール時にエラー「An error occurred while installing pg (1.2.3)」が発生した場合

rails6で、pgインストール時にエラー「An error occurred while installing pg (1.2.3), and Bundler cannot continue.」が発生した場合の原因と対処法。

環境

  • OS ubuntu20.10
  • ruby 2.7.2
  • rails 6.1.0

エラー内容

Gemfileに以下を追加して、

インストール時に発生

エラー全文

原因

ライブラリ「libpq-dev」がインストールされていなかったため

対処法

libpq-devをインストールする